[new_pkg] ripgrep-all ->

This commit is contained in:
Developer 2024-12-13 23:50:06 +00:00
parent a1a5b1ca56
commit 759f3f42b3
3 changed files with 82 additions and 0 deletions

22
kde/ripgrep-all/.PKGINFO Normal file
View File

@ -0,0 +1,22 @@
# Generated by makepkg 6.0.2
# using fakeroot version 1.33
pkgname = ripgrep-all
pkgbase = ripgrep-all
pkgver = 0.10.6-3
pkgdesc = rga: ripgrep, but also search in PDFs, E-Books, Office documents, zip, tar.gz, etc.
url = https://github.com/phiresky/ripgrep-all
builddate = 1734133805
packager = Tuxcore <dev@tuxcore.org>
size = 19098240
arch = x86_64
license = AGPL3
depend = ripgrep
depend = xz
optdepend = ffmpeg: for the ffmpeg adapter
optdepend = graphicsmagick: for the pdfpages adapter
optdepend = pandoc: for the pandoc adapter
optdepend = poppler: for the poppler adapter
optdepend = tesseract: for the tesseract adapter
makedepend = cargo
checkdepend = pandoc
checkdepend = poppler

49
kde/ripgrep-all/PKGBUILD Normal file
View File

@ -0,0 +1,49 @@
# Packager = Tuxcore <dev@tuxcore.org>
pkgname=ripgrep-all
pkgver=0.10.6
pkgrel=3
pkgdesc="rga: ripgrep, but also search in PDFs, E-Books, Office documents, zip, tar.gz, etc."
arch=('x86_64')
url='https://github.com/phiresky/ripgrep-all'
license=('AGPL3')
depends=('ripgrep' 'xz')
makedepends=('cargo')
checkdepends=('pandoc' 'poppler')
optdepends=(
'ffmpeg: for the ffmpeg adapter'
'graphicsmagick: for the pdfpages adapter'
'pandoc: for the pandoc adapter'
'poppler: for the poppler adapter'
'tesseract: for the tesseract adapter'
)
options=(!lto)
source=(
"${pkgname}-${pkgver}.tar.gz::https://github.com/phiresky/ripgrep-all/archive/refs/tags/v${pkgver}.tar.gz"
)
b2sums=('fc2618369c349fda5a78d3604b17b78788be73ce5925a5b6aa234627ccaa4b70dba8deddfc7cf5ef38dfe3c94d60a84956d9779110af2ff7ca44812774ffa28b')
prepare() {
cd ripgrep-all-${pkgver}
cargo fetch --locked --target "$(rustc -vV | sed -n 's/host: //p')"
}
build() {
cd ripgrep-all-${pkgver}
export RUSTUP_TOOLCHAIN=stable
export CARGO_TARGET_DIR=target
cargo build --frozen --release --all-features
}
check() {
cd ripgrep-all-${pkgver}
export RUSTUP_TOOLCHAIN=stable
cargo test --frozen --all-features
}
package() {
cd ripgrep-all-${pkgver}
install -Dm 755 target/release/rga "${pkgdir}"/usr/bin/rga
install -Dm 755 target/release/rga-preproc "${pkgdir}"/usr/bin/rga-preproc
install -Dm 755 target/release/rga-fzf "${pkgdir}"/usr/bin/rga-fzf
install -Dm 755 target/release/rga-fzf-open "${pkgdir}"/usr/bin/rga-fzf-open
}

View File

@ -0,0 +1,11 @@
--- aaa/src/adapters/pandoc.rs 2023-03-22 14:32:02.599432479 +0100
+++ bbb/src/adapters/pandoc.rs 2023-03-22 14:32:54.759429382 +0100
@@ -80,7 +80,7 @@
//.arg("--to=commonmark-header_attributes-link_attributes-fenced_divs-markdown_in_html_blocks-raw_html-native_divs-native_spans-bracketed_spans")
.arg("--to=plain")
.arg("--wrap=none")
- .arg("--atx-headers");
+ .arg("--markdown-headings=atx");
cmd
}
}